Issues

Please note this page is the community support for the free trial and does not guarantee timely response
Support requests for paid accounts should be reported through Azure support

  • The request must be chunked or have a content length.

    hello. When I do this curl -X POST "https://api.videoindexer.ai/{location}/Accounts/{accountId}/Videos?name={name}[&privacy][&priority][&description][&partition][&externalId][&externalUrl][&callbackUrl][&metadata][&language][&videoUrl][&fileName][&indexingPreset][&streamingPreset][&linguisticModelId][&personModelId][&sendSuccessEmail][&assetId][&brandsCategories][&accessToken] " and I Got this error. >HTTP Error 411. The request must be chunked or have a content length. How Do I define "chunked" or "content length"?

    Status: Proposed | Reported by Hidden Fri, 26 Jul 2019 09:19:13 GMT
  • cannot get auto detect language of my spanish video using my trial account in video indexer

    hi there, I am working on video indexer and read about auto detection of language function in video indexer i tried that with a spanish video and it is not detecting the language also it is not giving any transcript for the same. I have uploaded the video through api and the video gets uploaded but is not giving me any transcript. I am using trial account also i am not seeing the auto detect fucntion on the video indexer homepage as was shown in the screenshot of the LID in this link (https://azure.microsoft.com/en-us/blog/spoken-language-identification-in-video-indexer/) Please help me out as i am planning to buy a premium account for the same. Please reply asap. Thank you

    Status: Proposed | Reported by Hidden Thu, 25 Jul 2019 09:21:15 GMT
  • Indexer returns "Breakdown_not_found" errortype

    Hello, as suggested in the microsoft documentation were polling the result from the videoindexer via the api call. sadly since around 2 weeks i noticed that for most of our videos the videoindexer returns the error: {'ErrorType':'BREAKDOWN_NOT_FOUND','Message':'Base video 'xxxx' cannot be found.'}, this is happening on our new deployments and also on older deployments that didnt have this issue in the past. So far i was unable to find any systematic issue for why this is happening, i hope you could give me some insight on the issue. Thansk in advance, Alex

    Status: Proposed | Reported by Hidden Thu, 25 Jul 2019 09:14:25 GMT
  • Difference between Cognitive service and Video Indexer

    We are currently using Azure Cognitive services to: - track faces in our videos - extract faces and detect age, gender, emotion frame by frame - group faces to "identity" persons in the video (we just need to know that person A appears in frame x, y and z) - detect labels (environment, etc) So I was wondering if Cognitive services is superseded by Video Indexer and only Video Indexer will get all the improvements from now on? Also, if I am supposed to use Video Indexer, can I require just the features I am interested on? E.g I do not need indexing, search, audio transcription and more.

    Status: Proposed | Reported by Hidden Tue, 23 Jul 2019 14:32:18 GMT
  • Can't get access token: 500 Internal Server Error

        $ curl -v -X GET "https://api.videoindexer.ai/auth/uksouth/Accounts/<accountId>/AccessToken?allowEdit=False" -H "Ocp-Apim-Subscription-Key: <subscription-key>"
    Note: Unnecessary use of -X or --request, GET is already inferred.
    *   Trying 23.100.51.194...
    * TCP_NODELAY set
    * Connected to api.videoindexer.ai (23.100.51.194) port 443 (#0)
    * ALPN, offering h2
    * ALPN, offering http/1.1
    * Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
    * successfully set certificate verify locations:
    *   CAfile: /etc/ssl/cert.pem
      CApath: none
    * TLSv1.2 (OUT), TLS handshake, Client hello (1):
    * TLSv1.2 (IN), TLS handshake, Server hello (2):
    * TLSv1.2 (IN), TLS handshake, Certificate (11):
    * TLSv1.2 (IN), TLS handshake, Server key exchange (12):
    * TLSv1.2 (IN), TLS handshake, Server finished (14):
    * TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
    * TLSv1.2 (OUT), TLS change cipher, Client hello (1):
    * TLSv1.2 (OUT), TLS handshake, Finished (20):
    * TLSv1.2 (IN), TLS change cipher, Client hello (1):
    * TLSv1.2 (IN), TLS handshake, Finished (20):
    * SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
    * ALPN, server did not agree to a protocol
    * Server certificate:
    *  subject: CN=*.videoindexer.ai
    *  start date: Apr  8 13:51:10 2018 GMT
    *  expire date: Apr  8 13:51:10 2020 GMT
    *  subjectAltName: host "api.videoindexer.ai" matched cert's "*.videoindexer.ai"
    *  issuer: C=US; ST=Washington; L=Redmond; O=Microsoft Corporation; OU=Microsoft IT; CN=Microsoft IT TLS CA 2
    *  SSL certificate verify ok.
    > GET /auth/uksouth/Accounts/<accountId>/AccessToken?allowEdit=False HTTP/1.1
    > Host: api.videoindexer.ai
    > User-Agent: curl/7.54.0
    > Accept: */*
    > Ocp-Apim-Subscription-Key: <subscription-key>
    > 
    < HTTP/1.1 500 Internal Server Error
    < Content-Length: 111
    < Content-Type: application/json
    < x-ms-request-id: 7b4c2b9c-b395-43f4-9b04-456dbc1cd774
    < Request-Context: appId=cid-v1:c13c4029-b9c4-48d1-a23a-86b440ab35d4
    < Date: Mon, 01 Jul 2019 19:36:34 GMT
    < 
    * Connection #0 to host api.videoindexer.ai left intact
    { "statusCode": 500, "message": "Internal server error", "activityId": "7b4c2b9c-b395-43f4-9b04-456dbc1cd774" }
    
    
    
    I am trying to get my access token from the API but I get a 500 status response after ~45 seconds delay (seems to take abnormally long for the response to come, although I don't know what's normal). I took my account id from my account settings page on www.voiceindexer.ai and took the subscription key from a storage account I own on portal.azure.com

    Status: Proposed | Reported by Hidden Mon, 01 Jul 2019 20:03:41 GMT
  • Operation API: CORS

    How do we enable cors for our accounts? Is it possible to upload files directly from Javascript? Access to XMLHttpRequest at 'https://api.videoindexer.ai/trial/Accounts/{accountId}/Videos?name={videoName}&accessToken={token}&privacy=Private&callbackUrl={callbackUrl}&sendSuccessEmail=false' from origin 'http://localhost:8080' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource.

    Status: Proposed | Reported by Hidden Wed, 26 Jun 2019 22:10:48 GMT
  • JENNY LAM: HKBU

    Why does the video not playback on the rendered file emailed to me? Insights are great! Can you access my file via the link to check? https://www.videoindexer.ai/accounts/a4161212-c0ed-41bf-b889-d261fc8b018c/videos/dc350528a7/?location=Trial. I am a journalism leturer at Hong Kong Baptist University. I seem to be able to sign in with my university email. Does that mean my students too can have free access? I will also check with oir IT office. Butplease help with playback speed problem...in fact it does not play back at all

    Status: Proposed | Reported by Hidden Fri, 21 Jun 2019 05:00:41 GMT
  • Greek Support

    Do you have any plans for support of greek language?

    Status: Proposed | Reported by Hidden Sat, 15 Jun 2019 18:02:07 GMT
  • Cost of operations API

    Hello , i want to ask if i hit many times on opration API's like "Get Video Captions" or "Get Video Insights Widget" with any language, if the cost increased or not?

    Status: Proposed | Reported by Hidden Mon, 03 Jun 2019 09:14:43 GMT
  • indexing stopped at 94%

    now since indexing stopped no more video can be uploaded not it is getting deleted.

    Status: Proposed | Reported by Hidden Thu, 30 May 2019 19:51:29 GMT

You're not signed in. Please sign-in to report an issue or post a comment.